Article number
000003889
Affected Versions
All
Source Hypervisor
Hyper-V
Error: “The remote server returned an error: (403) Forbidden” During VRA Installation on Hyper-V Host
Viewed 216 times
Summary
This article covers a scenario in which a VRA installation will fail due to the the inability to download from the ZVM VM.
Root Cause
The Hyper-V host on which VRA will be installed fails to download the VRA installation file from the ZVM.
There may be multiple causes that could include proxy settings, anti-virus software, IE download settings in security settings of the ZVM.
There may be multiple causes that could include proxy settings, anti-virus software, IE download settings in security settings of the ZVM.
Symptoms
VRA installation failed with the following error:
Failed to install Zerto Hyper-V agent at host: <host name> due to error:Host:[Host <host ID> server <Server ID>]failed to download file:https://<ZVM IP>:9669/files//GetFile/zerto.hyperv.agent to local path:c:\ZertoAgent\ZVM\zerto.agent.zip due to error:The remote server returned an error: (403) Forbidden
Failed to install Zerto Hyper-V agent at host: <host name> due to error:Host:[Host <host ID> server <Server ID>]failed to download file:https://<ZVM IP>:9669/files//GetFile/zerto.hyperv.agent to local path:c:\ZertoAgent\ZVM\zerto.agent.zip due to error:The remote server returned an error: (403) Forbidden
Solution
Log on to the host and open the following link (found in the error) in Internet Explorer or Edge browser:
Check if the host has proxy settings for accessing the ZVM server:
2. Press shift and right-click at 'iexplorer.exe', run as a different user.
3. Supply the username for the SCVMM Run As account and password. (in the example, it is svc-svm-ScvmmRunAs)
4. Navigate to 'Internet options' from the Internet Explorer.
5. Under 'Security' tab, click 'custom level'.
6. Locate 'File download' and change it to 'enable'.
7. Reattempt the VRA installation.
- https://<ZVM IP>:9669/files//GetFile/zerto.hyperv.agent
Check if the host has proxy settings for accessing the ZVM server:
- If a proxy setting is defined, disable this and reattempt the VRA installation.
- If there is anti-virus software installed, disable anti-virus and reattempt the VRA installation.
- Determine the SCVMM Run As account. If the user does not know, this can be determined from ZVM logs.
00000000,c5dc97b0,18-09-03 14:28:16.49,E,44,VMMManager,ExecutePsCommand,"Cmdlet execution error. Command: Invoke-SCScriptCommand. Parameters: VMMServer=Microsoft.SystemCenter.VirtualMachineManager.Remoting.ServerConnection, VMHost=host.com, Executable=cmd.exe, CommandParameters= /c powershell.exe [Net.ServicePointManager]::SecurityProtocol = [Net.SecurityProtocolType](4032);[Net.ServicePointManager]::ServerCertificateValidationCallback = {$true};try{ (New-Object System.Net.WebClient).DownloadFile('https://<ZVM IP>:9669/files//GetFile/zerto.hyperv.agent', 'c:\ZertoAgent\ZVM\zerto.agent.zip');} catch [System.Net.WebException]{if($_.Exception.InnerException){ throw ([string]::Format('{0}. {1} Stack trace:{2}', $_.Exception.message, $_.Exception.InnerException.message, $_.Exception.InnerException.StackTrace))}else{throw ($_.Exception.message);}};, TimeoutSeconds=30, ScriptCommandSetting=Microsoft.SystemCenter.VirtualMachineManager.SCScriptCommandSetting, RunAsAccount=svc-svm-ScvmmRunAs. 0. [Error: 22632.0] Error Code : ScriptCommandStdErrMatchAnyStringError ; Message : The script command standard error matched the failure policy setting ""Match any string"" with its result The remote server returned an error: (403) Forbidden.
2. Press shift and right-click at 'iexplorer.exe', run as a different user.
3. Supply the username for the SCVMM Run As account and password. (in the example, it is svc-svm-ScvmmRunAs)
4. Navigate to 'Internet options' from the Internet Explorer.
5. Under 'Security' tab, click 'custom level'.
6. Locate 'File download' and change it to 'enable'.
7. Reattempt the VRA installation.