• This topic has 6 replies, 3 voices, and was last updated February 9, 2024 by George P.

How to silence VPG0043 error

  • How to silence VPG0043 error: The Microsoft default SAN policy

    Changing disks to online via disk part does not clear alert and we do not want to disable alert

    I was able to successfully change the SAN policy so that all disks on the VM are showing online in diskpart as per this article (https://kb.vmware.com/s/article/2000767) however the alert in Zerto did not go away.  We do not suppress the error since other VM’s we add to protect could have the same problem.  We do not want to find out there is a problem during recovery because the alert is suppressed.  How do we satisfy the alert without suppressing it?


    Please refer to the following KBs:





    Please read my previous post and response accordingly.  I’m not a fan of this way of troubleshooting a problem or working with a customer.  When I originally opened the case I was detailed in what I wanted answered.  Then this forum thread got opened and the case closed without even contacting me to discuss.  Then I get the same two articles as a response and my question still gets ignored.  Zerto support has been phenomenal until now.  This is a ding.  Please read my post above and answer my question.  Thanks in advance!

    Craig – I feel your pain!  A year and a half later on v8.5 Update 2, your question still is NOT answered, and we still have the same issue!  No way to silence the alert once we have “fixed” all the servers in the VPG with the diskpart command.

    Zerto Support – any movement on this?  Having yellow icons on all my VPGs replicating from on premises VMware to Azure isn’t helpful.  It doesn’t really tell me the overall state of replication, and as a “false positive” it dulls responses to actual issues.



    This is Kalsang from Zerto.

    We have this KB for it to silence it for almost a year now.

    The t_DisableCrossReplicationMonitor tweak is used to disable the “Microsoft Default SAN Policy” warning seen in the Zerto GUI.

    Default value is 0, which means the alert is active.
    Setting value to 1 will disable the alert from appearing on the site where configured.

    NOTE: Silencing the alert is for all current and future replicated VMs. Always follow this KB to ensure proper configuration of each protected VM.

    Source Hypervisor
    Where to Apply
    Both Sides
    Zerto Virtual Manager (ZVM)
    To configure this tweak on version 7.5 or higher, kindly follow this KB to properly utilize the Tweak Tool.

    To configure this tweak on versions prior to 7.0, kindly follow the below:

    1. Open the “tweaks.txt” file within /Program Files/Zerto/Zerto Virtual Replication/ on the ZVM.
    2. Add tweak “t_DisableCrossReplicationMonitor=1” to its own line in the text file and save the file.
    3. Restart ZVM service.
    4. Repeat for all paired sites where the alert is to be silenced.

    Let me know If that helps.

    Best regards,

    Hi Kalsang D,

    I too am seeing this false positive alert on VPGs replicating from VMware to Azure. I clicked your link to the tweak tool, but got a Salesforce logon prompt. I entered my zerto credentials but that didn’t work.

You must be logged in to create new topics. Click here to login