• This topic has 8 replies, 7 voices, and was last updated June 14, 2017 by Dan G.

PowerShell – Getting Started

  • I’ve found several posts/articles/blogs about running your first PowerShell CmdLets, etc.  However, I can’t find how you actually install those CmdLets.  If I run “add-pssnapin Zerto.PS.Commands”, PowerShell gives an error that “No snap-ins have been registered for Windows PowerShell version 4”.  I see the DLL of the same name in the Zerto installation folder, but I can’t figure out how to actually add the Snapin correctly.

    Secondarily, how do I get the CmdLets on another machine other than the ZVM?


    Hey Wally,

    Did you download and install the Zerto PS CMDlets from the software download section in MyZerto? I’d also recommend checking out the documentation section and reading the “Automating Zerto Virtual Replication with PowerShell and REST APIs Whitepaper v2.0.pdf” which removes the need to use the PS CMDlets for 95% of use cases. Any further questions let me know. Thanks,


    @Wally – Hopefully you got the cmdlets installed and are up and running.  If you are still working on this, I also went as far as creating a profile so the snapIn loads when I start PowerShell:

    <!–?xml version=”1.0″ encoding=”UTF-8″?–>

    By following the procedures outlined in the Technet document, How to Create a Windows PowerShell Profile, I effectively won’t need to run the “Add-PSSnapIn Zerto.PS.Commands” each time I open the PowerShell CLI.
    When the procedure gets to the point where you edit the “Microsoft.PowerShell_profile.ps1” in notepad, I added the following (one entry per line as seen below):
    <span style=”font-family: ‘Andale Mono’;”><b>Add-PSSnapIn Zerto.PS.Commands</b></span>
    <span style=”font-family: ‘Andale Mono’;”><b>Set-ExecutionPolicy RemoteSigned</b></span>
    <span style=”font-family: ‘Andale Mono’;”><b>. $profile</b></span>
    IT Professional with focus on VMware Virtualization and BCDR solutions.

    Sorry, to correct the above (I can’t edit my posts here for some reason with Chrome).

    What I added to the profile was:

    Add-PSSnapIn Zerto.PS.Commands

    Set-ExecutionPolicy RemoteSigned


    IT Professional with focus on VMware Virtualization and BCDR solutions.

    I have yet to come across ANY “downloads section” in MyZerto.  The only ‘menu’ choices are Home, Forums, Knowledge Base, Technical Documentation and Training.  Can someone please provide the actual link that takes a person to a download for the PowerShell cmdlets?  I keep getting lost in the various pages where I thought downloads might be, only to get further lost in the weeds.

    Hi Miguel V,

    At the top of the myZerto page (this page) you should see some navigation tabs that will bring you where you need to go.

    Under the “Technical Documentation” tab, you will find the Automation Whitepaper here (“White Paper – Automating Zerto Virtual Replication with PowerShell & REST APIs”).

    Also, if you see (you mentioned you don’t see it? I’m checking into this separately) a “Support & Downloads” tab, this is where you’ll find the download for the “Zerto Virtual Replication Cmdlets.”

    Gene (thanks!) provided some guidance above on installing them. I was going to provide more, but I don’t believe that’s even what you need/are asking.

    I hope this helps you to move forward!


    Follow me: www.twitter.com/HarrySiii

    Hi Harry,

    I have installed the zerto powershell cmdlets. But I am not able to run any of the command.

    Here is the error , I am  getting

    Get-CheckPoints : System.ServiceModel.CommunicationException: An error occurred while receiving the HTTP response to This could be
    due to the service endpoint binding not using the HTTP protocol. This could also be due to an HTTP request context being aborted by the server (possibly due to the service shutting
    down). See server logs for more details. —> System.Net.WebException: The underlying connection was closed: An unexpected error occurred on a receive. —> System.IO.IOException:
    Unable to read data from the transport connection: An existing connection was forcibly closed by the remote host. —> System.Net.Sockets.SocketException: An existing connection
    was forcibly closed by the remote host

    Hey All,

    I am getting the same endpoint binding issue, i am reviewing the Rest API Guide sounds like thats the way to go here. Do i run the scripts for the Rest APIs on my ZVM’s?


    Could someone provide a default Rest API script to , for example “get-protectiongroups” so i can have a baseline to work off?

    Thanks guys!

    Hey Guys this is what im working w/ right now ,



    add-pssnapin zerto.ps.commands

    Get-ProtectionGroups -SiteName $zertosite -ZVMIP $ZertoServer -ZVMPort $ZertoPort  -Username $ZertoUser -Password $ZertoPassword -SiteName $zertosite


    and i get a 503 error


    http://IP:9669/ZvmService/SiteController is unavailable



You must be logged in to create new topics. Click here to login