• This topic has 5 replies, 3 voices, and was last updated March 11, 2024 by DFRS I.

Connect to Linux ZVM from PowerShell

  • Hi, can anyone tell me how to connect to a Linux (10U3) ZVM from PowerShell 7, please? We’ve recently migrated ZVMs to Linux and are having issues.

    I’ve read the blog about the REST API but that isn’t what I’m trying to do. I want to be able to use the Zerto PowerShell Cmdlets, such as Connect-Zvm.

    Initially, the error was SSL related, so I ran Remove-ZvmSslCheck. The error now is:

    Connect-Zvm_Connect: The server responded with a Request Error, Status: NotFound

    We don’t currently have Active Directory authentication so have tried the admin and zadmin accounts. Do I need to create a new authentication method and, if so, can it be as simple as a username & password?

    You don’t need to create a new authentication method, but you can create an account in Keycloak on the ZVM: https://<ZVM IP>/auth.  Once you login, pick the zerto realm and create the account there.  All of our ZVMs are Linux, and we created an account on each ZVM in the zerto realm to automate tasks and monitor health.  I can post examples of how I authenticate, but they’re in Python.  I’m not much of a PowerShell person.


    Please make sure you are using the ZVML PowerShell package and not the ZVM PowerShell package as they are different.

    Link to the current latest ZVML package: https://www.powershellgallery.com/packages/Zerto.Zvml.Commandlets/1.0.953

    Thanks for the replies. I had uninstalled the older ZVM PowerShell, but it looks like it didn’t get removed properly. I had to delete the directory manually and the connect is now working.

    And now that I’m connected, how do I disconnect? The documentation page lists Disconnect-Zvm, but I don’t have that cmdlet available from this module.

    That’s great, thanks for confirming.

You must be logged in to create new topics. Click here to login