VM's removed from inventory?

  • Not really sure what happened.  I got an alert today that one of my VPG’s was paused because one or more VM’s were removed from inventory… but they weren’t.   Both VM’s from the VPG are in inventory, and up and running.  So I deleted the VPG and then tried to recreate it, but recreation fails with a “Protection group creation. Failed: Return code after CreateMirrorWithGrainPools was RcStorageError”.  Anyone have any idea what happened?  It looks like Zerto thinks that the VM’s are gone, but I can assure you that if they were someone would have let me know :).

    Do I need to remove the VM’s from inventory and then add them back in?

    What version are you running? I’m on v5.5 Patch1 and I had a very similar problem today. My situation was I deleted a perfectly healthy VPG. I then tried to recreate the VPG, and I got the exact same error as you. I was about to open a support ticket when I thought I’d just try again, in the event I did something wrong. 2nd time the VPG created successfully. Did you try to created it more than once?

    I’m curious now if this is a bug in v5.5.

    I am on the same version as you.  I figured I would let it sit overnight and revisit it this morning, but it didn’t do me any good.  Same issue.  I will open a ticket and have it looked at, and post back when we figure it out.

    So after I opened a ticket with support I re-read the error message.  I interpreted the “RcStorageError” to mean the Recovery Site data-store.  On a whim I created the VPG again and pointed it to a different LUN on the same Pure array, and it is working now.  It appears that there is something with that original target LUN that Zerto is not happy with.  I just so happened to direct the new VPG to that same LUN twice and got failures.  I will keep my ticket open and see if we can’t figure this out.

    We encountered the same issue, except we wanted to preseed our disk.

    To work around this we recreated the VPG and used a different default data store from where the recovery disks where. We had originally been trying to keep the default data store the same as the location of the recovery disks we wanted to use for preseeding. We then preseeded the disk and this worked.

    Our VPG is delta syncing now. I’ll update this post if we have any issues.

    Thanks to the guys who post before me.

    @Mike: did you get a solution from support? We also have the same issue also running on 5.5 Patch 1 and on a Pure array …
    The first time I created the VPG it failed with the RcStorageError. The second time the VPG creation was successful.


    We are having this issue regularly now. I’ve raised a case, Case # 00105602.

    Below is the end result of my ticket with Zerto:

    Deleting and re-creating the VPG from pre-seed would resolve this issue. The errors you are seeing  is now a known issue within the zdriver. The zdriver is the entity on the host that allows the communication between the ESXi host and the VRA itself.

    Another approach to clear up this error would be to reload the zdriver from the ESXi host. I have confirmed with our development team that a fix for this issue is actively being worked on. This is being tracked internally via bug 30706 (for reference). Please let me know which course of action you would prefer to take as both of them will clear up the issue for now.

    FWIW, the Technical Documentation for 5.5 U1 (released on or about September 10th) shows that this has been resolved.

You must be logged in to create new topics. Click here to login