• This topic has 1 reply, 1 voice, and was last updated December 9, 2019 by Aaron C.

Horribly slow API responses

  • 7.0 U2 VMware

    I’m running scripts on the ZVM itself. Just the authentication part to get the Zerto Session Token can take 30+ seconds. I’ve tried both powershell and PHP and they both experience the same lag. I’ve tried from a different server and the result is the same; the API acts like I’m sending requests from here to Tokyo through a 2400 baud modem from 1988.

    I’m trying to do simple updates for testing the PHP class I’ve created (not a fan of Powershell.) I’ve managed to get a copy of an existing VPG’s settings to a VPG settings identifier, then pull just the journal data via a GET, update the data in memory, and now I’m trying to PUT the updated data so I can commit the change.

    The PUT is where it dies. “cURL Error (56): OpenSSL SSL_read: Connection was reset” Every single time. Meanwhile the web GUI works fast and responsive, even across the WAN.

    I’ve tried restarting ZVM services, rebooting, everything.


    I should have had a working SOMETHING two days ago, but I can’t get it even most basic functions to work. What a horrible API this is.

    The slow initial auth was resolved by forcing IPV4:

    if (defined(‘CURLOPT_IPRESOLVE’) && defined(‘CURL_IPRESOLVE_V4’)){
    curl_setopt($curl, CURLOPT_IPRESOLVE, CURL_IPRESOLVE_V4);

    However, the PUT request to the API is still timing out.

    Upgraded to 7.5 and it’s the exact same result.

    cURL Error (56): OpenSSL SSL_read: Connection was reset

    All the other GET and POST calls are working as expected. If I change PUT to a POST, the API returns:

    HTTP/1.1 405 Method Not Allowed

    ..but it returns the error immediately. No timeout, no lag.

You must be logged in to create new topics. Click here to login