• This topic has 10 replies, 6 voices, and was last updated November 12, 2017 by Bruce M.

Failed to create application Zerto Cloud Appliance

  • Hello Everyone,

    We are installing Zerto Virtual Appliance on Azure Subscription. When we want to install Zerto Cloud Appliance return that error.

    Install File Name :  -Zerto_ZCA_Azure_Installer_5.0u1_5

    Please help us.

    Thanks for help.

    Hi Kadir,

    I’m sorry for the late reply. Are you deploying from the Azure Marketplace (Zerto Virtual Replication for Azure) and running the installer from the desktop?



    Follow me: www.twitter.com/HarrySiii


    I’m running into the same issue. I deployed the ZVR for Azure from the marketplace and am running the installer from the desktop. The 3 validation steps (ZVM communication, Azure credentials and Storage Accounts) were all successful.




    Hi All,

    unfortunatly I have the same problem.

    I I deployed the ZVR for Azure from the marketplace, then running the installer from the desktop.

    The 3 validation steps (ZVM communication, Azure credentials and Storage Accounts) were all successful.

    But installaton hangs

    Any Idea?




    Hello from Chile!

    Any new for this problem?….

    i do 2 processes to install ZCA in azure….

    1.- create a Vm Windows Server 2012 R2, with all inbound firewall enables, and then go to the browser and download the Zerto_ZCA_Azure_Installer_5.0.30.165 and install, but in the last step ocurrer an error.

    2.- I create a zerto imagen from the virtuals machines, too with the all firewall inbound enables and then open the VM and install the program and in the last step the same error…

    please any help?


    I’m currently working with Zerto support on this issue.

    It seems my account has problems accessing Azure AD which they believe is the root cause of the issues. My partner who created the tenant is currently looking at this to make sure my account has access to Azure AD.

    Can you check if the account used to install Zerto has access to Azure AD? If it does, it would mean this is not the problem and we’ll have to look elsewhere for a solution.




    hi ben!

    thanks. yea, mi account is a user access administrator and when i do this step in the installation, mi account es check ok.


    Jose Manuel.

    Hi Jose,

    Your user also needs sufficient rights in Azure AD. If you select the Limited Administrator directory role, I know the User Administrator role is a must. I also selected Password, Service and Privileged role administrator and Security reader.

    I still have to figure out which of those roles are necessary, but I do know once I made those changes, I was (finally) able to get things installed 🙂

    I hope it works out for you too!




    Hi ben!

    I tried and my account can”t access the azure active directory, then give me all the roles (password, service, security reader and privileged role administrator) and i can do the successfull instalation.

    Then i tried to discard the different directory and the installation it’s done with only the security reader.


    Zerto confirmed that the only required role should be User Administrator.

    This is now fixed it seems. No more issues. I deployed v5.5 and it works great.

You must be logged in to create new topics. Click here to login