Application: Zerto.Online.Services.Connector.exe

  • My service of zerto is falling from time to time. In the Event Viewer these two errors appear below. Does anyone know what I can do?

    [ Name] .NET Runtime

    EventID 1026
    Keywords 0x80000000000000

    EventData:

    Application: Zerto.Online.Services.Connector.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.Threading.Tasks.TaskCanceledException at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(System.Threading.Tasks.Task) at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(System.Threading.Tasks.Task) at Zerto.Zsa.Toolkit.Common.Api.HttpApiHelper+<RequestAsync>d__81[[System.Boolean, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]].MoveNext() at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(System.Threading.Tasks.Task) at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(System.Threading.Tasks.Task) at Zerto.Zsa.Agent.Transmitter.Services.CommonApiSessionKey+d__71[[System.Boolean, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]].MoveNext() at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(System.Threading.Tasks.Task) at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(System.Threading.Tasks.Task) at Zerto.Zsa.Agent.Transmitter.Services.ZvmApiClientService+<GetTransmitterEnableAsync>d__8.MoveNext() at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(System.Threading.Tasks.Task) at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(System.Threading.Tasks.Task) at Zerto.Zsa.Agent.Transmitter.Schedulers.HvmSamplesScheduler+<Execute>d__5.MoveNext() at System.Runtime.CompilerServices.AsyncMethodBuilderCore+<>c.<ThrowAsync>b__6_1(System.Object) at System.Threading.QueueUserWorkItemCallback.WaitCallback_Context(System.Object) at System.Threading.ExecutionContext.RunInternal(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean) at System.Threading.ExecutionContext.Run(System.Threading.ExecutionContext, System.Threading.ContextCallback, System.Object, Boolean) at System.Threading.QueueUserWorkItemCallback.System.Threading.IThreadPoolWorkItem.ExecuteWorkItem() at System.Threading.ThreadPoolWorkQueue.Dispatch() at System.Threading._ThreadPoolWaitCallback.PerformWaitCallback()

    [ Name] Application Error

    EventID 1000

    Keywords 0x80000000000000

    EventRecordID 210171

    EventData Zerto.Online.Services.Connector.exe

    6.0.0.38
    5d080203
    KERNELBASE.dll
    6.1.7601.23796

    59028e59

    e0434352

    0000c54f
    ffc

    01d62bdce40dcd27
    C:\Program Files\Zerto\Zerto Virtual Replication\Zerto Online Services Connector\Zerto.Online.Services.Connector.exe

    C:\Windows\syswow64\KERNELBASE.dll
    3015a11d-9941-11ea-97f9-000c29dfdeed

    Hello,

    Contara from Zerto Support.

    I checked in our database and prior cases for this error message:

    PublicKeyToken=b77a5c561934e089]].MoveNext() at System.Runtime.CompilerServices.TaskAwaiter.ThrowForNonSuccess(System.Threading.Tasks.Task) at System.Runtime.CompilerServices.TaskAwaiter.HandleNonSuccessAndDebuggerNotification(System.Threading.Tasks.Task) at Zerto.Zsa.Agent.Transmitter.Services.CommonApiSessionKey+d__7

    I’m not be able to fine the solution.

    Please open a support case and provide us the log file:

    In regards to the log gathering, please follow the next steps:

    1. Log to the recovery ZVM machine.
    2. Run Zerto Diagnostics
    3. Select the first option and click next
    4. Follow the steps and in every step select the parameters according to the following:
    Case Number: ######
    Timeframe: Enough hours to cover the issue
    Alerts: relevant
    VPGs: none
    Sites: relevant
    VRAs: none
    vCD: no
    Hypervisor: no
    Hosts: no

    Include the Windows application event viewer too.

    Thank you for your patience.

    Hello

    I have same error. What was the solution?

    THANKS

    Hi Alicia,

    Guy from Zerto here.

    Unfortunately, there isn’t a one-size-fits-all solution here for this issue.

    Therefore, I recommend gathering ZVM logs & an event viewer export and opening a support ticket with us.

    Best,

    Guy

     

You must be logged in to create new topics. Click here to login