Article number
000003575
Affected Versions
All
Source Hypervisor
VMware
Target Hypervisor
All

When Attempting to Create or Edit a VPG, the List of VMs to Protect is Incomplete

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Summary

An administrator may have difficulty finding VM(s) to add to a VPG for Zerto protection and are not currently in any other VPGs. Specifically, the VM(s) is/are not listed in the VMs list as part of the Create/Edit VPG wizard.

Root Cause

This is a known issue with VMware/VCenter where a VM's summary or Storage.summary attribute is set to 'unset'. This is passed along to Zerto of which handles as if the VM is not able to be protected.

Symptoms

When attempting to create or edit VPGs, the list of VMs to protect is incomplete/is missing VM(s).

ZVM logs will show an error like below:

VCenterProxy,GetVmFolderReflection,"Had an exception while trying to retrieve VmReflection for [VM vm-xxx, server {server_UID}]. Ignoring that VM.","Zerto.Zvm.Common.VCenterProxyException Zerto.Zvm.Common.VirtualizationManager.VCenter.VirtualMachineReflection VMEntityInformationToVMReflection(Zerto.Zvm.Common.VirtualizationManager.VCenter.VMIdentifier, VCenterConnectionLayer.EntityInformation.VirtualMachineEntityInformation, Zerto.Zvm.Common.VirtualizationManager.VCenter.DatastoreIdentifier, Zerto.Zvm.Common.VirtualizationManager.VCenter.FolderIdentifier, System.Collections.Generic.IEnumerable`1[Vim25Api.HostScsiDisk], System.Collections.Generic.IEnumerable`1[VCenterConnectionLayer.EntityInformation.DistributedVirtualPortgroupEntityInformation], System.Collections.Generic.IEnumerable`1[VCenterConnectionLayer.EntityInformation.OpaqueNetworkEntityInformation], System.String) Zerto.Zvm.Common.VCenterProxyException: VM {VM_NAME} has an unset Summary or Summary.storage property

Additionally, upon further review in the VCenter MOB entry for this VM/Storage (https://<vcenter_id>/mob/?moid=<vm-moref>&doPath=storage), the Summary or Summary.storage property on the page will read as 'unset'.

Solution

There are two options to take to resolve/workaround this issue:

  1. Contact VMware support to resolve the 'unset' summary or summary.storage property. Once resolved, Zerto will receive the new update as part of the reflection collection flow and list the VM as expected.

  2. The other option is to remove the affected VM from inventory, then re-add to inventory. This, of course, is a much more disruptive option than the above.