Problem with VPG Entering ‘Needs Configuration’ Status Overnight Or During 3rd Party Backups
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Summary
An administrator may notice VPG(s) suddenly entering 'Needs Configuration' status after seemingly no actions taken on the VPGs.
Root Cause
Some backup solutions take a snapshot of each VM to be backed up, attach the disk the snapshot is stored on to a proxy server to validate the snapshot, and then detach the snapshot disk from said proxy server. If a Zerto protected VM is used as a proxy server for such backup solutions, all of these snapshots will be validated via said VM. This means a storm of disks will be attached, validated, then removed.
Zerto sees the new protected disks on the VMs, creates new mirrors on the Recovery site, and starts to sync them. Before the disks can be synced fully, they are pulled from the VM. Therefore, there are missing configuration details (disks) on the protected VM to get this VPG back into sync. Hence, 'Needs Configuration' status is reported.
Symptoms
VPG(s) enter 'Needs Configuration' status. Also, the following alert will be active in the Zerto GUI:
VPG {vpg_name} is missing configuration details
Solution
Follow the below steps to resolve VPG(s) impacted by this issue:
If the affected VPG only has the 1 VM, unfortunately the VPG must be recreated.
If the affected VPG has many VMs, simply edit the VPG to remove the problematic VM, save the VPG, then edit once more and add the VM back in.
NOTE: Ensure to follow the steps for Preseeding a Volume if it is preferred over a fresh initial sync of the mirrors.
To permanently resolve this issue, follow the below steps:
Ensure all protected VMs in the affected VPG are not being used as a Proxy Server for the back up solution.
Alternatively, remove the protected VMs from the backup solution entirely and utilize Zerto's Long Term Retention (LTR) functionality instead.