Article number
000003422
Affected Versions
All
Source Hypervisor
Azure
Target Hypervisor
AWS

Problem with ZCA will not Pass Beyond the License Page, Preventing Successful Login to Zerto GUI

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Summary

An administrator may suddenly not be able to login to a ZCA as the only screen that is provided is the License Key entry form, which was previously already provided at install.

Root Cause

The Zerto License has expired.

Symptoms

ZCA GUI will not present a login form, instead it requests a License Key to be provided. The ZCA was previously licensed and paired to another site. There will also be no way to skip this screen.

ZVM logs will present the following errors:

Alert "'Your license has expired. Contact your <a href='mailto:salesteam@zerto.com'>account manager</a> to renew your license. Note: Protection of virtual machines continues.'" was turned on.

VisualQueryErrorHandler,ProvideFault,Encountered unhandled exception in service. Final exception to throw: Zerto.Infra.ZertoException: Failed to save license : License is expired,"Zerto.Common.Gui.GuiVisibleException Void SaveLicense(Zerto.Zvm.Common.Licensing.LicenseKey) Zerto.Common.Gui.GuiVisibleException: Failed to save license : License is expired at Zerto.Zvm.Services.VisualQueries.VisualQueryService.SaveLicense(LicenseKey licenseKey) in E:\dalmore_u4\dev\system\Zvm\Services\VisualQueries\VisualQueryService.cs:line 2363 at DynamicModule.ns.Wrapped_VisualQueryService_c6d148689c4146d3b68e5dd194b6153c.<SaveLicense_DelegateImplementation>__113(IMethodInvocation inputs, GetNextInterceptionBehaviorDelegate getNext)"

Please contact your Account Manager to renew the license. With a valid license, you will be able to log in.

Solution

To resolve this issue, kindly contact your Account Manager or Systems Engineer to assist in renewing your license and then provide the new license key to the form.

Note: Replication will not be impacted.