Problem with VRA Service not Starting After Installation/Upgrade of Zerto Version 8.0
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Summary
An administrator may experience after upgrading a ZCA with multiple disks and Zerto being installed on a driver other than C:, the VRA service on the ZCA is not able to start. This results in replication being severed to/from said ZCA.
Root Cause
Zerto is installed onto a drive in the ZCA that is not the C drive, which is supported.
During the install, however, Zerto will install the keys necessary for the VRA service to C:\Program Files\Zerto\Zerto Virtual Replication\Secrets rather than to the location "Drive letter":\Program Files\Zerto\Zerto Virtual Replication\Secrets.
Symptoms
After installation of Zerto 8.0 the customer sees the following at the end of the installation wizard:
Configuration Engine Failed to start services.
The VRA service will not start and if attempts are made to start it, the following is found in Event Viewer logs:
Windows could not start the Zerto Virtual Replication Appliance service on Local Computer.
Error 1067: The process terminated unexpectedly
The following error can also be found in the Event Viewer logs:
The Zerto Virtual Replication Appliance service terminated unexpectedly. It has done this 1 time(s). The following corrective action will be taken in 120000 milliseconds: Restart the service.
Administrators will also notice the ZCA is disconnected from the peer site VRAs and replication will be down.
Solution
To workaround this issue, follow the steps below:
Copy the files from C:\Program Files\Zerto\Zerto Virtual Replication\Secrets to "Drive letter":\Program Files\Zerto\Zerto Virtual Replication\Secrets where "Drive letter" is the driver where Zerto was actually installed.
Attempt to start the Windows services once more and monitor the Zerto GUI.
A permanent fix was provided in Zerto version 8.5. Upgrading to version 8.5 will avoid this issue from occurring.