Article number
000003891
Affected Versions
7.5
7.0
Source Hypervisor
vCD
Target Hypervisor
vCD

Problem with Networks Missing in Create/Edit VPG Wizard After Upgrading to Zerto 7.0 or Higher

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Summary

An administrator may notice there are missing network selections when editing/creating a VPG that is to replicate to a VCD site.

Root Cause

Starting in Zerto 7.0, the VCD reflection is collected using the VCD API, rather than the SDK.  We have seen several instances where many API timeouts are seen in the Zerto logs on VCD sites containing lots of vApps.  This would generally be expected in a VCD to VCD environment where a CSP offers IaaS services to their customers, which includes DR between two sites that they control.  

Zerto leverages the RestSharp client to send API requests to VCD. We have found when a very large number of requests are sent concurrently, timeouts will start to be seen. By default, the default timeout for the RestSharp client is 100 seconds. Using Fiddler we have found that the requests that time out are indeed taking longer than 100 seconds to process.

After working with VMware Support / Engineering, they have recognized that there is some "inefficient code" specifically around the networkConnectionSection calls, especially when there are vApps containing 20+ VMs. They do plan on improving this in the future.

Symptoms

This situation would most commonly occur for VCD to VCD customers in an IaaS configuration.  The reason for this is that the VCD reflection has to contain quite a few vApps that Zerto is trying to collect network info for.  The most common timeout that we see in the logs or VCD reflection tool would be the following:

RestUtils,Execute,"Get request failed. baseUrl:https://172.25.2.106/api/vApp/vm-9ac8aa43-41ab-4c86-acde-dc84738fdb0a/networkConnectionSection. resource:. headers:Accept => application/*+xml;version=32.0, x-vcloud-authorization => 2c335f5080fd4ab2baf97ab92d7f6772 expectedStatusCode: OK response != null: True response?.StatusCode: 0 response?.Content: response?.ContentType: response?.ContentEncoding: response?.ContentLength: 0 response?.ErrorMessage: The operation has timed out

The most likely consequence of this would be missing network mappings on the NICs tab of the VPG configuration Wizard (i.e., protected networks will be missing and thus cannot be mapped to recovery networks).  This will make it so that the IP may need to be manually configured upon failover.

Solution

To resolve this issue, upgrading to 7.5 Update 3 or higher is required. In this version is a new RestSharp API timeout extension up to 5 minutes. Should this 5 minute timeout still be hit, kindly engage Zerto Support to increase the timeout via a configuration change.