Article number
000003144
Affected Versions
All
Source Hypervisor
All
Target Hypervisor
All

Problem with ‘Cannot open database “zvm_db” requested by the login. The login failed’ After In-Place Windows OS Upgrade For A ZVM

Viewed 87 times

Summary

An administrator may need to upgrade the Windows OS that runs on the ZVM itself. Post-upgrade, the administrator may notice the GUI is not accessible and the ZVM service is stuck in a crash loop.

Root Cause

During the Windows OS upgrade of the ZVM, the LocalDb instance that runs as local system loses its configuration. When the 'Embedded database' service starts, it creates the instance but the database is missing. The database files (*.mdf & *.ldf) exist on the ZVM so they simply need to be attached back to the instance post-upgrade.

Symptoms

After an in-place Windows OS upgrade for a ZVM, the ZVM service cannot start properly. This leads to an inability to launch the Zerto UI for this site and also results in checkpoints to not be replicated properly.

In the ZVM logs, an exception will be seen similar to the below which states the login failed to the ZVM Database file:

"Cannot open database ""zvm_db"" requested by the login. The login failed.
Login failed for user 'sazerto'.","FluentNHibernate.Cfg.FluentConfigurationException NHibernate.ISessionFactory BuildSessionFactory() FluentNHibernate.Cfg.FluentConfigurationException: An invalid or incomplete configuration was used while creating a SessionFactory. Check PotentialReasons collection, and InnerException for more detail."

Solution

Kindly engage Zerto Support and cite this article to assist with the workaround.