No Zerto Tab in vCenter due to wrong ZVM IP

KB Number:
000001314

Symptoms:
When opening vSphere client or vCenters web GUI - no Zerto tab is currently present, even while Zerto was installed with no issues.

Cause:
Zerto was not updated with the current ZVM IP causing the vCenter Plug-in to point to an incorrect ZVM IP. 

Solution:

1. Modify the pubsplugin.xml file to point to the correct IP
        a. Log into the ZVM machine.
        b. Backup D:\Program Files (x86)\Zerto\Zerto Virtual Replication\gui\pubsplugin.xml (or within the applicable installation folder).
        c. Edit pubsplugin.xml replacing each entry of the old IP address with the correct IP address.

2. Remove the misdirected plug-in from the vCenter MOB.
        a. Navigate to http://vCenter_Server_name_or_IP/mob.
        b. Follow the VMware KB to remove ‘unwanted plugins’.  The name is ‘Zerto Replication Plugin’.

        To remove unwanted plug-ins from the Available Plug-ins list:
                1. Click Content.
                2. Click ExtensionManager.
                3. Select and copy the name of the plug-in you want to remove from the list of values under Properties.
                4. Click UnregisterExtension.  A new window appears.
                5. Paste the name of the plug-in and click Invoke Method. This removes the plug-in.
                6. Close the window.
                7. Refresh the Managed Object Type:ManagedObjectReference:ExtensionManager window to verify that the plug-in is removed successfully.
        Note: If the plug-in still appears, you may have to log out of and back into the vSphere.

3. Open the Zerto Virtual Replication Diagnostics
        a. Log into the ZVM machine.
        b. Ensure the ZVM has an interface that can reach vCenter.  An additional vNIC may be needed.
        c. Run the ‘Reconfigure Zerto Virtual Manager’ wizard within the Zerto Diagnostics tool.
        d. When you get to the ‘Zerto Virtual Manager Communication’ screen, select the ZVM interface that can reach vCenter.
        e. Run the reconfigure if the ‘Validation’ wizard is all green, if not revisit the failed item.
        f. Confirm your ability to connect via vSphere.


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