Article number
000004076
Affected Versions
7.5 Update 3
7.5 Update 2
7.5 Update 1
7.5 Patch 1
7.5
7.0 Update 3
7.0 Update 2 Patch 2
7.0 Update 2 Patch 1
7.0 Update 2
7.0 Update 1 Patch 1
7.0 Update 1
7.0 Patch 2
7.0 Patch 1
7
6.5 Update 4 Patch 1
6.5 Update 4
6.5 Update 3 Patch 1
6.5 Update 3
6.5 Update 2
6.5 Update 1 Patch 1
6.5 Update 1
6.5
7.5 Update 4 Patch 2
Source Hypervisor
All
Target Hypervisor
AWS

Error: “Conversion Task Limit (5) Exceeded” when Recovering to AWS

Viewed 296 times

Summary

An administrator receives a limit exceeded error when trying to recover to AWS and is unsure of how to get around this limit.

Root Cause

There is a limitation in AWS when performing ZImport for Data Volumes and AWS Import import methods for Recovery to AWS as it relies on the AWS import API. This API has since been deprecated by AWS and Zerto has since removed the ZImport for Data Volumes and AWS Import method types.

Symptoms

Administrator performs a Recovery Operation to AWS which fails with the below error:

Conversion Task Limit (5) Exceeded

Solution

To workaround this issue, there are three options available:

  1. Request AWS Support to increase the limit on the number of current conversion tasks from 5 to a higher number which matches their needs. After this is increased, attempt the Recovery Operation once more.

  2. Edit the VPG's import method to ZImport for All Volumes which does not utilize the AWS Import APIs at all which avoids the conversion task limitation entirely.

  3. Upgrade Zerto to at least 8.0 which deprecated/removed import method selection as all VPGs will use ZImport for All Volumes moving forward.

Note: If option 2 or 3 is preferred, ensure Zerto Tools for Windows and/or Zerto Tools for Linux are executed on all protected VMs in said VPG ahead of next Failover attempt.