Article number
000003554
Affected Versions
7.5
6.5
7.0
Source Hypervisor
Azure
Target Hypervisor
Azure

Error: “Windows Server 2012 R2 the installation of KB2999226 and its prerequisites KB2919355 and KB2919442 is required” When Installing Azure ZCA

Viewed 300 times

Summary

An administrator may run into an Azure ZCA installation error when Windows 2012 R2 is the operating system of choice.

Root Cause

This is a known issue in the installer code.

There are several versions of Tiworker on the instance and the latest TiWorker version was not identified correctly.
In the installation logs, there is an entry 'TiWorker Version is: 6.3.9600.16384', which is older than the required version (6.3.9600.17031), but there are later versions on the instance not being identified.

Symptoms

Customer deployed an Azure instance (not from market place) running Windows 2012 R2, but ZCA failed to be installed due to the error below:

Installation failed because on Windows Server 2012 R2 the installation of KB2999226 and its prerequisites KB2919355 and KB2919442 is required.

Applying the mentioned prerequisites and retrying the installation does not resolve the issue.

Solution

This issue was resolved in 8.0. It is recommended to run the 8.0 installation package to avoid the issue.

If there is an earlier code version desired than 8.0, kindly contact Zerto Support for a workaround on the ZCA.